mplayer mit Compiz betreiben

Vor einiger Zeit hatte ich vor, als Fenstermanager konsequent auf Compiz zu setzen. Leider scheiterte dieser Plan bisher vor allem an zwei inkompatiblen Programmen:

  1. OpenOffice.org Impress, die freie PowerPoint-Alternative: im Präsentationsmodus wird das Panel, also die Taskleiste, über der Folie angezeigt.
  2. mplayer, der beliebte Video-Allesfresser: das Bild flackert stark, hin und wieder stürzt der auch einfach ab

Gegen 1) habe ich noch kein Mittel gefunden, außer, für eine Präsentation auf den XFCE-Fenstermanager xfwm4 umzuschalten. Kann ich mit leben, da die wenigsten Beamer mit der von meinem Laptop bevorzugten Auflösung von 1400x1050 Pixeln problemlos zurechtkommen und ich daher sowieso die Einstellungen ändern muss.

Problem 2) ist dagegen sehr ärgerlich. Das Flackern hängt mit der Technik zusammen, die der bevorzugte und (zumindest bei mir) performanteste Video-Ausgabetreiber 'xv' nutzt. Sie verursacht Konflikte mit den Methoden, die Compiz einsetzt, um die Fenster zu rendern. Das Problem ist schon länger bekannt, aber der allgemeine Workaround war bisher, einen alternativen Ausgabetreiber wie 'x11' zu nutzen und den (nicht von 'x11' unterstützten) Vollbildmodus durch die Software rendern zu lassen:

mplayer -vo x11 -zoom -fs video.mpg

Keine schöne Lösung, da die Vergrößerung durch die Software aufwendig ist und das Video daher oftmals ruckelt. Heute bin ich durch Zufall auf einen Artikel in SmSpillaz' Blog gestoßen, welcher den von David Reveman geschriebenen mplayer-xv-Patch mplayrepatch.patch beschreibt. Dieser behebt das Problem, indem es (vereinfacht gesagt) die problematischen Aufrufe nicht an die Grafikkarte, sondern an Compiz übergibt.

Ich war ein bisschen skeptisch, aber tatsächlich, es funktioniert und ich stelle keine fühlbaren Performanzeinbußen fest. Und es klappt auch, wenn Compiz mal nicht aktiv ist. Für Gentoo-User habe ich den Patch in die aktuelleste stabile Version (1.0_rc2_p26753-r1) des mplayer-ebuilds eingebaut. Einfach die Datei mplayer-mplayrepatch-ebuild.zip in das lokale Portage-Overlay entpacken und mplayer neu kompilieren (sorry für die ZIP-Datei, tgz wurde von der Wordpress-Installation hier nicht akzeptiert).

Comments

Hm, darf ich anmerken, dass ich mit beiden Programmen keine Probleme habe unter Ubuntu samt Compiz? :D

Mit xv als Videoout?

Jap, grad nochmal explizit mit -vo xv gestartet, keine Probleme.

Dann schätze ich mal, dass dort der Patch schon eingespielt ist. Würde mich interessieren, was sie an OpenOffice modifiziert haben...

Das kann man bestimmt nachgucken. Welche Compiz Version hast du denn?

Neuste SVN-Version. Denke aber, dass Problem wird an OpenOffice liegen, und Compiz kann höchstens nen Workaround dafür bereitstellen.

Hm, ich hab nur 0.7.4.
Naja, da sieht man wieder, welches die überlegene Distribution ist! *hust* *flamewar anfang* :P ;)

Add new comment